%global debug_package %{nil}
%global commit ac8e070f42d7dab64edebb2dc6d7c62e8df1abe6
%global shortcommit %(c=%{commit}; echo ${c:0:7})
%global gituser samoht0
%global gitcounter 6
Name: xdccget
Version: 1.1.git.%{gitcounter}
Release: %{shortcommit}%{?dist}
Summary: Download files from IRC with XDCC from command line
License: GPL-2.0-only
Group: System/Console
Url: https://github.com/%{gituser}/%{name}
Source0: %{url}/tarball/%{commit}#/%{gituser}-%{name}-%{shortcommit}.tar.gz
BuildRequires: openssl-devel gcc devscripts
%description
This is a project that allows you to download files from IRC with XDCC with an
easy and simple to use command line tool like wget or curl.
%prep
%autosetup -n %{gituser}-%{name}-%{shortcommit}
%build
%set_build_flags
export CFLAGS=$(echo "$CFLAGS -fdata-sections -ffunction-sections" | sed -e 's| -g | |')
export LDFLAGS=$(echo "$LDFLAGS -Wl,-s,--gc-sections")
%make_build
%install
install -Dm755 %{name} %{buildroot}%{_bindir}/%{name}
hardening-check -v %{name}
%files
%{_bindir}/%{name}
%doc README.md
%license LICENSE
%changelog
* Tue Jul 04 2023 samoht0 git-master
- using my own fork repository based on TheBurningDust/xdccget-for-windows
* Tue Sep 14 2021 samoht0 git-master
- OpenSSL 3.0 adjustments (see github for commit details)
* Fri Feb 26 2021 samoht0 git-master
- spec and history cleanup
- using my own fork repository