## START: Set by rpmautospec
## (rpmautospec version 0.3.5)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
    release_number = 6;
    base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
    print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec

# Generated by rust2rpm 24
# * missing dev-dependencies: codegenrs, snapbox
%bcond_with check
%global debug_package %{nil}

%global crate anstyle-parse

Name:           rust-anstyle-parse
Version:        0.2.0
Release:        %autorelease
Summary:        Parse ANSI Style Escapes

License:        MIT OR Apache-2.0
URL:            https://crates.io/crates/anstyle-parse
Source:         %{crates_source}

BuildRequires:  cargo-rpm-macros >= 24

%global _description %{expand:
Parse ANSI Style Escapes.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/README.md
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+core-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+core-devel %{_description}

This package contains library source intended for building other packages which
use the "core" feature of the "%{crate}" crate.

%files       -n %{name}+core-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+utf8-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+utf8-devel %{_description}

This package contains library source intended for building other packages which
use the "utf8" feature of the "%{crate}" crate.

%files       -n %{name}+utf8-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
# git add LICENSE-APACHE LICENSE-MIT benches/parse.rs examples/parselog.rs src/lib.rs
# git add src/params.rs src/state/codegen.rs src/state/definitions.rs src/state/mod.rs
# git add src/state/table.rs README.md Cargo.toml
# git commit -a -m 'go'

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
* Sat Apr 15 2023 Tom Callaway <spot@fedoraproject.org> - 0.2.0-6
- Uncommitted changes

* Sat Apr 15 2023 Tom Callaway <spot@fedoraproject.org> - 0.2.0-5
- go

* Sat Apr 15 2023 Tom Callaway <spot@fedoraproject.org> - 0.2.0-4
- go

* Sat Apr 15 2023 Tom Callaway <spot@fedoraproject.org> - 0.2.0-3
- go

* Sat Apr 15 2023 Tom Callaway <spot@fedoraproject.org> - 0.2.0-2
- go

* Sat Apr 15 2023 Tom Callaway <spot@fedoraproject.org> - 0.2.0-1
- go

* Sat Apr 08 2023 Fabio Valentini <decathorpe@gmail.com> - 0.1.1-1
- Initial import (#2183202)