# Created by pyp2rpm-3.3.2
%global pypi_name betamax-matchers

Name:           python-%{pypi_name}
Version:        0.4.0
Release:        1%{?dist}
Summary:        A VCR imitation for python-requests

License:        ASL 2.0

URL:            https://github.com/sigmavirus24/betamax_matchers
Source0:        https://github.com/betamaxpy/betamax_matchers/archive/%{version}/%{pypi_name}-%{version}.tar.gz
BuildArch:      noarch

BuildRequires:  python3-devel
BuildRequires:  python3dist(setuptools)

BuildRequires:  python3-betamax
BuildRequires:  python3-requests-toolbelt
BuildRequires:  python3-pytest

%description
betamax_matchers Experimental set of Matchers for Betamax < that may possibly
end up in the main package.JSON Body Matcher --Usage:.. code-block:: python
from betamax_matchers.json_body import JSONBodyMatcher from betamax import
Betamax Betamax.register_request_matcher(JSONBodyMatcher)Form URL Encoded Body
Matcher --Usage:.. code-block:: python from betamax_matchers.form_urlencoded
import...

%package -n     python3-%{pypi_name}
Summary:        %{summary}
%{?python_provide:%python_provide python3-%{pypi_name}}

Requires:       python3dist(betamax) >= 0.3.2
Requires:       python3dist(requests-toolbelt) >= 0.4.0
%description -n python3-%{pypi_name}
betamax_matchers Experimental set of Matchers for Betamax < that may possibly
end up in the main package.JSON Body Matcher --Usage:.. code-block:: python
from betamax_matchers.json_body import JSONBodyMatcher from betamax import
Betamax Betamax.register_request_matcher(JSONBodyMatcher)Form URL Encoded Body
Matcher --Usage:.. code-block:: python from betamax_matchers.form_urlencoded
import...


%prep
%autosetup -n betamax_matchers-%{version}
# Remove bundled egg-info
rm -rf %{pypi_name}.egg-info

%build
%py3_build

%install
%py3_install

%check
py.test-3

%files -n python3-%{pypi_name}
%license LICENSE
%doc README.rst
%{python3_sitelib}/betamax_matchers
%{python3_sitelib}/betamax_matchers-%{version}-py?.?.egg-info

%changelog
* Fri Jan 18 2019 Ben Rosser <rosser.bjr@gmail.com> - 0.4.0-1
- Initial package.