## START: Set by rpmautospec
## (rpmautospec version 0.6.0)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
    release_number = 1;
    base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
    print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec

Name:           python-pytest-check
Version:        2.4.1
Release:        %autorelease
Summary:        A pytest plugin that allows multiple failures per test 

License:        MIT
URL:            https://github.com/okken/pytest-check
Source:         %{pypi_source pytest_check}

BuildArch:      noarch
BuildRequires:  python3-devel

%global _description %{expand:
A pytest plugin that allows multiple failures per test.}

%description %_description

%package -n python3-pytest-check
Summary:        %{summary}
%description -n python3-pytest-check %_description


%prep
%autosetup -n pytest_check-%{version}


%generate_buildrequires
%pyproject_buildrequires


%build
%pyproject_wheel


%install
%pyproject_install
%pyproject_save_files pytest_check


%check
%pytest


%files -n python3-pytest-check -f %{pyproject_files}
%license LICENSE.txt
%doc README.md


%changelog
## START: Generated by rpmautospec
* Mon Sep 02 2024 Packit <hello@packit.dev> - 2.4.1-1
- Update to 2.4.1 upstream release
- Resolves: rhbz#2309113

* Tue Aug 27 2024 Packit <hello@packit.dev> - 2.4.0-1
- Update to 2.4.0 upstream release
- Resolves: rhbz#2308200

* Fri Jul 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 2.3.1-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild

* Fri Jun 07 2024 Python Maint <python-maint@redhat.com> - 2.3.1-3
- Rebuilt for Python 3.13

* Thu May 09 2024 Cristian Le <cristian.le@mpsd.mpg.de> - 2.3.1-2
- Add packit automation

* Thu May 09 2024 Cristian Le <cristian.le@mpsd.mpg.de> - 2.3.1-1
- Initial import (fedora#2279108)
## END: Generated by rpmautospec