%global pypi_name sphinxcontrib-htmlhelp
# when bootstrapping sphinx, we cannot even run an import check
%bcond check 1
# RHEL does not include html5lib, without which the tests fail
%bcond tests %[%{with check} && %{undefined rhel}]
Name: python-%{pypi_name}
Version: 2.0.0
Release: 12%{?dist}
Summary: Sphinx extension for HTML help files
License: BSD-2-Clause
URL: http://sphinx-doc.org/
Source0: %{pypi_source}
BuildArch: noarch
# In Sphinx 5 path.read_text() replaces path.text() - compatibility fix
Patch: https://github.com/sphinx-doc/sphinxcontrib-htmlhelp/pull/16.patch
BuildRequires: gettext
BuildRequires: python%{python3_pkgversion}-devel
BuildRequires: python%{python3_pkgversion}-setuptools
%if %{with check}
BuildRequires: python%{python3_pkgversion}-sphinx >= 1:2
%if %{with tests}
BuildRequires: python%{python3_pkgversion}-pytest
BuildRequires: python%{python3_pkgversion}-html5lib
%endif
%endif
%description
sphinxcontrib-htmlhelp is a sphinx extension which renders HTML help files.
%package -n python%{python3_pkgversion}-%{pypi_name}
Summary: %{summary}
%{?python_provide:%python_provide python%{python3_pkgversion}-%{pypi_name}}
%description -n python%{python3_pkgversion}-%{pypi_name}
sphinxcontrib-htmlhelp is a sphinx extension which renders HTML help files.
%prep
%autosetup -p1 -n %{pypi_name}-%{version}
find -name '*.mo' -delete
%build
for po in $(find -name '*.po'); do
msgfmt --output-file=${po%.po}.mo ${po}
done
%py3_build
%install
%py3_install
# Move language files to /usr/share
pushd %{buildroot}%{python3_sitelib}
for lang in `find sphinxcontrib/htmlhelp/locales -maxdepth 1 -mindepth 1 -type d -not -path '*/\.*' -printf "%f "`;
do
test $lang == __pycache__ && continue
install -d %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES
mv sphinxcontrib/htmlhelp/locales/$lang/LC_MESSAGES/*.mo %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES/
done
rm -rf sphinxcontrib/htmlhelp/locales
ln -s %{_datadir}/locale sphinxcontrib/htmlhelp/locales
popd
%find_lang sphinxcontrib.htmlhelp
%if %{with check}
%check
%py3_check_import sphinxcontrib.htmlhelp
%if %{with tests}
%{__python3} -m pytest
%endif
%endif
%files -n python%{python3_pkgversion}-%{pypi_name} -f sphinxcontrib.htmlhelp.lang
%license LICENSE
%doc README.rst
%{python3_sitelib}/sphinxcontrib/
%{python3_sitelib}/sphinxcontrib_htmlhelp-%{version}-py%{python3_version}-*.pth
%{python3_sitelib}/sphinxcontrib_htmlhelp-%{version}-py%{python3_version}.egg-info/
%changelog
* Thu Aug 10 2023 Karolina Surma - 2.0.0-12
- Declare the license as an SPDX expression
* Fri Jul 21 2023 Fedora Release Engineering - 2.0.0-11
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
* Fri Jun 16 2023 Python Maint - 2.0.0-10
- Rebuilt for Python 3.12
* Tue Jun 13 2023 Python Maint - 2.0.0-9
- Bootstrap for Python 3.12
* Fri Jan 20 2023 Fedora Release Engineering - 2.0.0-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
* Fri Jul 22 2022 Fedora Release Engineering - 2.0.0-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
* Thu Jul 07 2022 Karolina Surma - 2.0.0-6
- Fix compatibility with Sphinx 5
* Mon Jun 13 2022 Python Maint - 2.0.0-5
- Rebuilt for Python 3.11
* Mon Jun 13 2022 Python Maint - 2.0.0-4
- Bootstrap for Python 3.11
* Fri Jan 21 2022 Fedora Release Engineering - 2.0.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
* Fri Jul 23 2021 Fedora Release Engineering - 2.0.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
* Fri Jun 11 2021 Karolina Surma - 2.0.0-1
- Update to 2.0.0
Resolves: rhbz#1963358
* Thu Jun 03 2021 Python Maint - 1.0.3-5
- Rebuilt for Python 3.10
* Wed Jun 02 2021 Python Maint - 1.0.3-4
- Bootstrap for Python 3.10
* Wed Jan 27 2021 Fedora Release Engineering - 1.0.3-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
* Wed Jul 29 2020 Fedora Release Engineering - 1.0.3-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
* Thu Jun 04 2020 Charalampos Stratakis - 1.0.3-1
- Update to 1.0.3 (#1699073)
* Sat May 23 2020 Miro Hrončok - 1.0.1-8
- Rebuilt for Python 3.9
* Fri May 22 2020 Miro Hrončok - 1.0.1-7
- Bootstrap for Python 3.9
* Thu Jan 30 2020 Fedora Release Engineering - 1.0.1-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
* Thu Oct 03 2019 Miro Hrončok - 1.0.1-5
- Rebuilt for Python 3.8.0rc1 (#1748018)
* Fri Aug 16 2019 Miro Hrončok - 1.0.1-4
- Rebuilt for Python 3.8
* Thu Aug 15 2019 Miro Hrončok - 1.0.1-3
- Bootstrap for Python 3.8
* Fri Jul 26 2019 Fedora Release Engineering - 1.0.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
* Fri Mar 01 2019 Miro Hrončok - 1.0.1-1
- Initial package