# Created by pyp2rpm-3.3.7
%global pypi_name zabbix-api
%global pypi_version 0.5.4

Name:           python-%{pypi_name}
Version:        %{pypi_version}
Release:        1%{?dist}
Summary:        Zabbix API

License:        GNU LGPL 2.1
URL:            https://github.com/gescheit/scripts
Source0:        %{pypi_source}
BuildArch:      noarch

BuildRequires:  python3-devel
BuildRequires:  python3dist(setuptools)

%description
This is an implementation of the Zabbix API in Python. Please note that the
Zabbix API is still in a draft state, and subject to change.Implementations of
the Zabbix API in other languages may be found on the wiki.Zabbix 1.8, 2.0,
2.2, 2.4, 3.0 and 3.2 are supported. Python 2 and 3 are supported.Future
versions must be supported too, if there is no deep changes.Installation: pip
install...

%package -n     python3-%{pypi_name}
Summary:        %{summary}
%{?python_provide:%python_provide python3-%{pypi_name}}

%description -n python3-%{pypi_name}
This is an implementation of the Zabbix API in Python. Please note that the
Zabbix API is still in a draft state, and subject to change.Implementations of
the Zabbix API in other languages may be found on the wiki.Zabbix 1.8, 2.0,
2.2, 2.4, 3.0 and 3.2 are supported. Python 2 and 3 are supported.Future
versions must be supported too, if there is no deep changes.Installation: pip
install...


%prep
%autosetup -n %{pypi_name}-%{pypi_version}
# Remove bundled egg-info
rm -rf %{pypi_name}.egg-info

%build
%py3_build

%install
%py3_install

%files -n python3-%{pypi_name}
%doc README.md
%{python3_sitelib}/__pycache__/*
%{python3_sitelib}/zabbix_api.py
%{python3_sitelib}/zabbix_api-%{pypi_version}-py%{python3_version}.egg-info

%changelog
* Tue Nov 30 2021 mockbuilder - 0.5.4-1
- Initial package.