## START: Set by rpmautospec
## (rpmautospec version 0.5.1)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
    release_number = 6;
    base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
    print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec

# Generated by rust2rpm 23
%bcond_without check
%global debug_package %{nil}

%global crate simdutf8

Name:           rust-simdutf8
Version:        0.1.4
Release:        %autorelease
Summary:        SIMD-accelerated UTF-8 validation

License:        MIT OR Apache-2.0
URL:            https://crates.io/crates/simdutf8
Source:         %{crates_source}

Patch:          0001-remove-harmful-deny-warnings-lint.patch

BuildRequires:  rust-packaging >= 21

%global _description %{expand:
SIMD-accelerated UTF-8 validation.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE-Apache
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%doc %{crate_instdir}/wasm32-development.md
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+aarch64_neon-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+aarch64_neon-devel %{_description}

This package contains library source intended for building other packages which
use the "aarch64_neon" feature of the "%{crate}" crate.

%files       -n %{name}+aarch64_neon-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+aarch64_neon_prefetch-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+aarch64_neon_prefetch-devel %{_description}

This package contains library source intended for building other packages which
use the "aarch64_neon_prefetch" feature of the "%{crate}" crate.

%files       -n %{name}+aarch64_neon_prefetch-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+hints-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+hints-devel %{_description}

This package contains library source intended for building other packages which
use the "hints" feature of the "%{crate}" crate.

%files       -n %{name}+hints-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+public_imp-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+public_imp-devel %{_description}

This package contains library source intended for building other packages which
use the "public_imp" feature of the "%{crate}" crate.

%files       -n %{name}+public_imp-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+std-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+std-devel %{_description}

This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.

%files       -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
## START: Generated by rpmautospec
* Sat Jan 27 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.4-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild

* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.4-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild

* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.4-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild

* Wed Jan 11 2023 Fabio Valentini <decathorpe@gmail.com> - 0.1.4-3
- Remove harmful deny(warnings) lint

* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.4-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild

* Wed May 25 2022 Fabio Valentini <decathorpe@gmail.com> - 0.1.4-1
- Update to version 0.1.4; Fixes RHBZ#2071249

* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.3-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild

* Thu Aug 05 2021 Rémi Lauzier <remilauzier@protonmail.com> - 0.1.3-1
- Initial import; Fixes RHBZ#1980617
## END: Generated by rpmautospec