## START: Set by rpmautospec
## (rpmautospec version 0.5.1)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
    release_number = 2;
    base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
    print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec

# Generated by rust2rpm 25
%bcond_without check
%global debug_package %{nil}

%global crate fsio

Name:           rust-fsio
Version:        0.4.0
Release:        %autorelease
Summary:        File System and Path utility functions

License:        Apache-2.0
URL:            https://crates.io/crates/fsio
Source:         %{crates_source}
# Automatically generated patch to strip dependencies and normalize metadata
Patch:          fsio-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes
# * drop benches and docs; non existent / should not be shipped
#   see https://github.com/sagiegurari/fsio/pull/11
Patch:          fsio-fix-metadata.diff

BuildRequires:  cargo-rpm-macros >= 24

%global _description %{expand:
File System and Path utility functions.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/README.md
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+rand-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+rand-devel %{_description}

This package contains library source intended for building other packages which
use the "rand" feature of the "%{crate}" crate.

%files       -n %{name}+rand-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+temp-path-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+temp-path-devel %{_description}

This package contains library source intended for building other packages which
use the "temp-path" feature of the "%{crate}" crate.

%files       -n %{name}+temp-path-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
## START: Generated by rpmautospec
* Fri Jan 26 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild

* Sun Oct 29 2023 Michel Lind <salimma@fedoraproject.org> - 0.4.0-1
- Initial package
## END: Generated by rpmautospec