## START: Set by rpmautospec
## (rpmautospec version 0.2.5)
%define autorelease(e:s:pb:) %{?-p:0.}%{lua:
    release_number = 2;
    base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
    print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{?dist}
## END: Set by rpmautospec

# Generated by rust2rpm 20
%bcond_without check

%global crate zopfli

Name:           rust-%{crate}
Version:        0.5.0
Release:        %autorelease
Summary:        Rust implementation of a compression algorithm

# Upstream license specification: Apache-2.0
License:        ASL 2.0
URL:            https://crates.io/crates/zopfli
Source:         %{crates_source}
# Initial patched metadata
# Downgrade typed-arena to version 1.7
Patch0:         zopfli-fix-metadata.diff

ExclusiveArch:  %{rust_arches}

BuildRequires:  rust-packaging

%global _description %{expand:
Rust implementation of the Zopfli compression algorithm.}

%description %{_description}

%package     -n %{crate}
Summary:        %{summary}
# MIT
# MIT or ASL 2.0
# Unlicense or MIT
# zlib
License:        MIT and ASL 2.0 and Unlicense and zlib

%description -n %{crate} %{_description}

%files       -n %{crate}
%license COPYING
%doc CONTRIBUTING.md CONTRIBUTORS README.md
%{_bindir}/zopfli

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages
which use "%{crate}" crate.

%files          devel
%license COPYING
%doc CONTRIBUTING.md CONTRIBUTORS README.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use "default" feature of "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
* Sat Jan 22 2022 Fedora Release Engineering <releng@fedoraproject.org> 0.5.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild

* Mon Jan 17 2022 Rémi Lauzier <remilauzier@protonmail.com> 0.5.0-1
- Update to version 0.5.0; Fixes RHBZ#2035116

* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> 0.4.0-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild

* Mon May 31 2021 Rémi Lauzier <remilauzier@protonmail.com> - 0.4.0-1
- Initial package